Results 1 to 2 of 2
  1. #1
    Suspended
    Join Date
    Apr 2004
    Location
    Out there
    Posts
    6,777

    Unhappy Blew the subwoofer

    Saw a spark come from the back of my B&W 800 ASW subwoofer above the heatsink and then a medium pitched hum from the speaker. No blown AC fuses, but I don't have a way to check the paper bound internal fuses. This happened after I adjusted the low-pass filter. My receiver allows me to set the crossover freq for the subwoofer and according to the subs owner's manual, the filter should be set to 80Hz, which is where I had the HTR 5740's setting. I don't think that has anything to do with it though, but as my post count shows, I'm new at this high end audio stuff.

    One thing I noticed about this circa 1995 - 1998 sub is the fact that the owner's manual shows the Mode switch positions labeled as "THX" & "Audio", as well as having a THX label on the volume control knob. My particular unit shows "Video" & "Audio". I imagine this means that THX was either an option or my sub pre-dates this feature. I did toggle this switch at the time I was setting the filter and while everything was under power.

    I guess what I'm asking the group is if anyone's had a similar situation, what did you do? I have contact information for the U.S parts distributor for B&W, but I'm not sure what parts to order, and I'd rather not take it to a repair shop if it's just a matter of swapping in a new PCB. I'm not the original owner, and obviously it's now out of warranty.

    I sure would appreciate any help/advice anyone may have to offer. Thanks.

    Rich

  2. #2
    DIY Dude poneal's Avatar
    Join Date
    Sep 2003
    Location
    TX, USA
    Posts
    677
    Don't know what you did (or maybe the unit was old and ready to go) but if I was rich in texas I would just buy a new sub :-)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Subwoofer & DSP
    By jackz4000 in forum Home Theater/Video
    Replies: 16
    Last Post: 04-24-2004, 10:19 AM
  2. Looking for a Subwoofer under $400
    By agidol in forum Speakers
    Replies: 10
    Last Post: 04-08-2004, 12:40 PM
  3. Replies: 4
    Last Post: 04-03-2004, 04:22 PM
  4. Do you know if this subwoofer is any good?
    By polo13 in forum Speakers
    Replies: 6
    Last Post: 12-13-2003, 12:43 PM
  5. Looking to buy a new subwoofer....need advice
    By bullion in forum General Audio
    Replies: 12
    Last Post: 12-04-2003, 04:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •