Results 1 to 3 of 3
  1. #1
    AR Newbie
    Join Date
    Nov 2004
    Posts
    2

    Why won't my CA Azur 540A switch on?

    Every time I try and switch on my Cambridge Audio Azur 540A amp with a second pair of speakers plugged in and switched on, the protection light flashed and it won't turn on. I have a pair of Mordaunt Short 902s as the primary 'A' pair and Gale Gold Moniter Mk2s as the 'B' pair. I've examined the manual and the CAP5 system explanation and I've tried all the different troubleshooting tips. I've tried reconnecting all the speakers, making sure there are no short circuits and it works until I connect the 4th speaker, even if is one of the 902s. I can turn on the B speakers after I turn on the amp and it seems to work fine but I don't want to do it if it's damaging the amp.

    I would be very grateful to anyone who could give me some advice.

    Thanks

  2. #2
    Just passing thru topspeed's Avatar
    Join Date
    Jun 2003
    Location
    California
    Posts
    3,607
    I have no idea what is going on with your Azur, but I know somebody that does. Try pm'ing this guy. Tons of Fun is our resident CA and Mordaunt Short tech support. He's in Britain so give him time to reply.

    Hope this helps.

  3. #3
    AR Newbie
    Join Date
    Nov 2004
    Posts
    2
    Thanks a lot
    I'll give it a go. Luckily, I'm in Britain too and so I've decided that the coincidence is a sign and that everything will work out ok.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Cambridge Audio Azur 540A VS. NAD C320 BEE
    By Walker in forum Amps/Preamps
    Replies: 80
    Last Post: 01-03-2006, 03:29 PM
  2. ISO 5.1 component audio switch box
    By bag in forum Cables
    Replies: 1
    Last Post: 07-11-2004, 11:33 AM
  3. 6-cable analog audio switch?
    By bag in forum General Audio
    Replies: 3
    Last Post: 07-09-2004, 10:55 AM
  4. Need help with speaker impedance switch...
    By clc77fm in forum General Audio
    Replies: 2
    Last Post: 05-15-2004, 08:12 AM
  5. Arcam CD62T vs Cambridge Audio Azur 540C
    By xforce in forum Digital Domain & Computer Audio
    Replies: 0
    Last Post: 02-28-2004, 07:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Latest AudioReview Articles

Hot Deals

Latest News

AudioReview on Facebook