Hi - New to the community. I've joined because of an issue with a Cowon X 7 player that I have not been able to resolve on the Cowon site - which is pretty meager in its product support. The computer no longer recognizes the device when it's plugged into a USB port. It happened a few hours after it was recognized and nothing unusual happened either in the disconnection or reconnection nor any changes to the computer in between. The obvious question is device driver but there is no specific driver included with the new player and none on the Cowon website. It uses a generic Windows 7 driver which Windows says is functioning normally. It's not identified in a way that I can download a new one from MS - and an uninstall - search for updates didn't bring up a new one so I used system restore to put back the prior copy. When the player is plugged in now the computer gives a message that the device is not recognized and the player just begins charging the battery or goes directly to play mode. In an internet search this is a common problem that no one has resolved. A search for drivers does bring up results but they're from companies with unrecognizable (to me) names - and they are .zip files which I am not about to execute without knowing that it's a safe source. Any helpful responses would be appreciated. I tried everything I could think of including resetting the player to factory defaults, updating the firmware (which is really just internal) and trying different USB ports. This happened once before last year and after a day or two it suddenly was recognized again. So far that hasn't happened and am not counting on it.