Results 1 to 2 of 2
  1. #1
    AR Newbie Registered Member
    Join Date
    Mar 2006
    Posts
    2

    Spark and smoke in my receiver - please help

    Tonight at 7pm, for the first time all day, I turned on our Marantz Receiver. As it was turned on, there was a "spark" sound, a flash of light, and subtle smoke in a very specific area on the top of the receiver. If you are looking down at the top of the receiver, it is in the upper right quadrant, slightly right and up from center. I shined a flashlight in the "grill" and it looked like several tiny gray wires were in the area of the spark.

    The video signal was great, but there was absolutely NO audio - no tivo "bleeps," to TV audio, switching to DVD, CD and tuner - no sound.

    FYI, it is now 10:30 at there is a faint "hum" of a fan sound that has been audible since this incident.

    Any ideas? I'm clueless but my husband is pretty good with this. Is it fixable?
    Thanks!

  2. #2
    Forum Regular
    Join Date
    Oct 2005
    Posts
    844
    I sounds like you've let all the smoke out. These receivers are engineered with only so much smoke and when it's gone, it's gone:-)

    Seriously, since you don't have sound from any input you may have blown something in the pre-amp. Usually, if the problem was with the power supply or the outputs were blown the receiver wouldn't turn on. It's probably fixable, but depending on the age of the receiver it may be more cost effective to replace it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Latest AudioReview Articles

Hot Deals

Latest News

AudioReview on Facebook