Results 1 to 2 of 2
  1. #1
    AR Newbie
    Join Date
    Apr 2004
    Posts
    1

    Question problem with sony str-d611

    Hi there,

    I have recently acquired an old Sony STR-D611 receiver, and upon my plugging it in, discovered that only a minimal amount of sound actually comes from my speakers. I have tried re-wiring the speaker setup, using different speakers/wires, plugging the speakers into the surround/center channels, and a multitude of curse words.... to no avail. If I crank the vlume up to the maximum, I hear a signal coming out of the speakers, and it is not distorted... It's as if someone put a volume limiter on the controls. I turned the mute button on an off a few times, and tried pressing and turining every switch and knob I could find on it. Still no progress... any help? thanks!

    -bryan

  2. #2
    Forum Regular
    Join Date
    Dec 2001
    Location
    Toronto CAN
    Posts
    144
    Quote Originally Posted by darkeagle
    Hi there,

    I have recently acquired an old Sony STR-D611 receiver, and upon my plugging it in, discovered that only a minimal amount of sound actually comes from my speakers. I have tried re-wiring the speaker setup, using different speakers/wires, plugging the speakers into the surround/center channels, and a multitude of curse words.... to no avail. If I crank the vlume up to the maximum, I hear a signal coming out of the speakers, and it is not distorted... It's as if someone put a volume limiter on the controls. I turned the mute button on an off a few times, and tried pressing and turining every switch and knob I could find on it. Still no progress... any help? thanks!

    -bryan
    Bryan,

    Check to make sure all connections are tight, and that the polarity of the speaker wires are correct. By 'sound quality' you are referring to volume right? What is the sensitivity rating of your speakers? If you don't know, tell us what brand and model they are.

    It could be that you have bought a lemon. Did you listen to it before you bought it?

    THOB

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Search for perfect hometeater
    By aurobindo_saha in forum Home Theater/Video
    Replies: 13
    Last Post: 04-15-2004, 10:18 AM
  2. SONY TV's and BURN-In -- LEGAL REMEDIES
    By dimitri001 in forum General Audio
    Replies: 0
    Last Post: 03-03-2004, 12:44 PM
  3. Is it logical to buy a Sony CDP-XA7ES for around 1000$ brand new?
    By iBug in forum Digital Domain & Computer Audio
    Replies: 5
    Last Post: 02-20-2004, 09:24 PM
  4. Hitachi Progressive Scan Problem
    By culp4684 in forum Home Theater/Video
    Replies: 0
    Last Post: 01-12-2004, 09:50 AM
  5. Harman Kardon FL 8350 problem with cd´s
    By Oceanblue in forum General Audio
    Replies: 0
    Last Post: 11-27-2003, 03:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Latest AudioReview Articles

Hot Deals

Latest News

AudioReview on Facebook