Results 1 to 2 of 2
  1. #1
    Forum Regular
    Join Date
    Jan 2004
    Posts
    5

    Question AMV 20 making screeching noise

    Help,

    I recently purchased a demo model Anthem AVM 20 and hooked it up to my system. When it plays for about an hour it starts making a slight screeching noise through the speakers. I know itís not the amp, Citation 7.1s. I hooked up a NAD L40 to the amp and it didnít make the same noise. I changed out the speaker cables too, no luck. I knew that was probably not the cause but Iím trying to rule everything out. I made sure none of the cables or interconnects are touching power cords so Iím not getting cross talk. I wouldnít think I got a bum unit but I guess itís possible. The only other thing I can think of is the building is really old and the outlet could be bad. Ok at this point Iím shooting in the dark. Help please.

    Vansonrider

  2. #2
    Suspended markw's Avatar
    Join Date
    Dec 2001
    Location
    Noo Joisey. Youse got a problem wit dat?
    Posts
    4,659
    It's not the old outlet or house wiring that's causing your problems.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Surface noise, Deutsche Grammophone
    By jbangelfish in forum Analog Room
    Replies: 15
    Last Post: 08-27-2004, 08:47 AM
  2. Noise, Noise, NOISE!!!
    By RJ Hanson in forum Analog Room
    Replies: 6
    Last Post: 02-19-2004, 08:54 AM
  3. Noise, Noise, NOISE!!!
    By RJ Hanson in forum Home Theater/Video
    Replies: 1
    Last Post: 01-27-2004, 04:49 PM
  4. How to clean up sorround noise?
    By Remi in forum Home Theater/Video
    Replies: 2
    Last Post: 12-29-2003, 11:16 AM
  5. Quest Speaker Noise
    By joel2762 in forum Speakers
    Replies: 2
    Last Post: 12-16-2003, 08:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •