Results 1 to 4 of 4
  1. #1
    Stainmaster Finch Platte's Avatar
    Join Date
    Nov 2003
    Location
    Fumbuck
    Posts
    2,628

    Getting frustrated with my sub hookup

    This is crazy. I have a system with Klipsch speakers and a Klipsch powered sub. Used it for years, and when the sub's amp blew up for the second time, I put it in storage. Not gonna buy another amp, if they even make them.

    I have a Sony powered sub I'd like to use, but it only has an RCA jack in the back. When I tried to cobble a Radio Shack cable together to hook it up, I got a loud buzz and my receiver flashed a warning sign.

    Why was I able to use the Klipsch powered sub for all those years, but now I can't use the Sony just because it has RCA jacks?

    For the record, the Klipsch sub had terminals for speaker wire, no RCA.

  2. #2
    Stainmaster Finch Platte's Avatar
    Join Date
    Nov 2003
    Location
    Fumbuck
    Posts
    2,628
    Lol, just like RR, lots of views, no replies.


  3. #3
    Forum Regular
    Join Date
    Mar 2002
    Location
    St. Louis, MO, USA
    Posts
    10,178
    What connection are you using from the receiver? The RCA input on your sub is a low level input and would have to be connected to a RCA sub out. Speaker terminal hook up is too hot for RCA input.
    Mark Levinson #512 SACD & 532h power
    Pass Labs XP-10 preamp
    Clearaudio Performance DC & Maestro v2 E, AcousTech Ph-1p
    Clarus Crimson loom - AC outlet to speaker terminal
    JBL 4367's & SAM3ha
    Revel S30's & SVS PC13 Ultra (sub)
    Marantz BD-7003 > AV-8003 > LINN 5125
    Transparent cables / Tributaries HDMI
    PS Audio Quintet & Surgex SA15&20

  4. #4
    Phila combat zone JoeE SP9's Avatar
    Join Date
    Jun 2003
    Location
    Philadelphia, PA
    Posts
    2,703
    A speaker level input and signal are very different from an RCA (line) level input and signal. They are not interchangeable. You're lucky the only thing your receiver did was go into protect mode.
    ARC SP9 MKIII, VPI HW19, Rega RB300
    Marcof PPA1, Shure, Sumiko, Ortofon carts
    Marantz CD63SE, Yamaha DVD-S1800
    DAC's: MSB Link, Behringer UCA222, Emotiva XDA-2, HiFimeDIY, Accuphase T101 tuner, Teac V-7010
    Emotiva UMC-200 processor, 2 Adcom GFA-545, 2 modified Dynaco MK3's, 2 bridged Crown XLS-402, Behringer CX2310, DBX223sx, Behringer DSP1124P,2 12" Transmission Line Subs (PASS DIY El-Pipe-O), Magnepan 1.7 (fronts), Acoustat Model 1 ESL's/SPW-1 Woofer (rears)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •