So I woke up this morning, and turned on my system to listen to a little radio while I read in bed. Everything was fine until I tried to turn the volume up with my remote. Nothing happened. So I figured "dead batteries" and swapped them out. Still didn't work. The manual volume control is fine and the amp is working as it should. Then I noticed that the green "power on" light was in fact, not on. Now here's the weird thing... the light goes on and stays on for about 2 seconds every time I try to use the remote. Normally the light stays on and blinks slightly when the amp gets an input from the remote. I decided then to unplug the amp and let it rest for a few hours. I plugged it in about 10 minutes ago and turned it on. Every time I turn the amp on or off I turn the volume all the way down, as it has a tendency to "thump" the speakers. As soon as I turned it on, the volume ratcheted up to almost the 12:00 position even though I hadn't touched it and the remote wasn't even pointing in it's direction. The remote still doesn't adjust the volume, and the power light still comes on and stays on for the roughly 2 seconds that it did before. Anyone else ever have this sort of thing go on?