Magnepan speakers

Printable View

  • 10-03-2008, 01:12 PM
    freu0047
    Magnepan speakers
    Hi guys,
    I was just using my home theater system, I have audiosource amp and pre amp, and some floor standing magnepan speakers, and all of the sudden, the sound was just super tinny, with little to no treble, and far too much bass.
    Is there a chance that the treble part of the speaker blew out, but the rest of it is fine?
    I don't know alot about speakers, but I am willing to tinker with it.
    If nessecary I can get you the model number and any more information.
    These speakers are aprox 29 years old, and they have been recoiled once about 15 years ago, is it time to get that done again?
  • 10-03-2008, 01:14 PM
    blackraven
    Did you check and see if the amp and preamp sound ok with any other speakers? It could be a problem on that end. If the amp and preamp work with other speakers then its the Maggies. Call Magnepan, their number is listed on their web site www.magnepan.com
    Their tech support is excellent.

    Also, are both speakers affected. If they are, its most likely on the amp/pre side. It would be unusual for both speakers to go at the exact same time.
  • 10-03-2008, 01:20 PM
    freu0047
    Quote:

    Originally Posted by blackraven
    Did you check and see if the amp and preamp sound ok with any other speakers? It could be a problem on that end. If the amp and preamp work with other speakers then its the Maggies. Call Magnepan, their number is listed on their web site www.magnepan.com
    Their tech support is excellent.

    Also, are both speakers affected. If they are, its most likely on the amp/pre side. It would be unusual for both speakers to go at the exact same time.

    Hi there, appreciate the quick response, I was actually just bringing some of my smaller speakers downstairs from my theater system in my room to test them, I'll let you know as soon as I get it tested.
  • 10-03-2008, 01:31 PM
    freu0047
    Hi again,
    I just tested the amp/pre amp with other speakers and it sounded fine, I guess my speakers finally went again :(

    Also, I tested each channel, one speaker sounds much much worse then the other, but both of them are definatly not at their optimal performance right now.

    Anyways, is there any chance that it could just be a blown fuse or should I get on the phone with magnepan?

    Thanks again
    -Sam
  • 10-03-2008, 06:51 PM
    blackraven
    I would call Magnepan, they should be able to point you to then problem for just the cost of a phone call. I live 20 minutes from Magnepan and have been to their factory. They are very nice and willing to help with problems or concerns.
  • 10-04-2008, 03:59 PM
    freu0047
    Quote:

    Originally Posted by blackraven
    I would call Magnepan, they should be able to point you to then problem for just the cost of a phone call. I live 20 minutes from Magnepan and have been to their factory. They are very nice and willing to help with problems or concerns.

    Yeap, I know the area well.
    Was born and raised in bloomington, MN.
    I'm up in Duluth now.

    Thanks for the help, appreciate it.