"Dead" Right Surround

Printable View

  • 03-20-2005, 10:24 AM
    ThreeDHomer
    "Dead" Right Surround
    Posting this here and in Home Theater forum. I am getting very little output from my right surround. The only thing I can think of is that the speaker wire running under my house might be pinched. Would that affect sound? The hook ups are fine, and when speakers are switched same problem exists. The speaker is making noise, just muted. Is my receiver shot?
  • 03-20-2005, 11:30 AM
    Rock789
    run new wire and see if the problem is still there...
    if the two conductors are shorting to eachother, it may damage your amp!

    Mike
  • 03-22-2005, 06:36 PM
    meephis
    yes you need to do a little bit of basic troubleshooting like doule checking the connectors from source to receiver, settings on the receiver, settings on the source and checking the wire, if its the wire it does need to be taken care of immediatley because you will short out your receiver. But since you said that the speaker wire runs under your house i would try just hooking up a new cable in the room just to see if thats the problem before you go through the trouble of getting under the house. :) So give it the run through and see whats happening, i doubt it is a speaker problem but if it comes down to it try hooking the speaker up to a different channel and then hook another speaker up to the problem channel and see what happens
  • 03-23-2005, 03:48 PM
    Rock789
    he already tried switching speakers...
    I just ment, run the wire on the ground, but like you said, hooking up any other wire already there will aslo work...