Results 1 to 5 of 5
  1. #1
    AR Newbie Registered Member
    Join Date
    Oct 2009
    Posts
    3

    Need help with my TV!!!

    Iím new here so please forgive me if Iím missing anything. I have a Toshiba HDTV (65H84) and I just bought a Yamaha receiver (RXV665) and I canít get any picture on my TV.
    I basically went HDMI from my sat box to the receiver and HDMI out to the TV. I get sound, but no picture. Iíve tried different settings on the TV (not much to change) Iíve tried every setting on the receiver. Iíve even bought new HDMI cables just to be sure. I got it working at one point but once I turned off the receiver I never got picture again. Iíve called Best Buy(pointless), Crutchfield(charged me $30 just to tell me my TV is not compatible), Yamaha(says itís the TV), and Toshiba(says itís the receiver). Iím about to give up. Can someone give me any hope?????????

  2. #2
    Suspended markw's Avatar
    Join Date
    Dec 2001
    Location
    Noo Joisey. Youse got a problem wit dat?
    Posts
    4,659

    Try isolating the problem.

    The first thing I would try is running the tv directly from the cable box. Assuming the HDMI cable is good, this should give you an incredible picture and whatever sounfd the tv is capable of.

    Once this is done, then try the other HDMI cable. This should produce the same result and now you'll know te TV and both cables work.

    Now, the only variable would be the receiver. I'd check the connections and setup very carefully (these are NOT intuitive). but the possibility of a handshaking issue between the STB and the receiver is always a possibility.

    If you had an upconverting DVD (or a blu-ray) player you could test with another source.

  3. #3
    AR Newbie Registered Member
    Join Date
    Oct 2009
    Posts
    3
    Thanks, for the info. I did test the cables (sat box to TV) and they work fine. I believe I’m having a problem with the “handshake” between the receiver and TV like you said. I tried unplugging (AC) the TV, receiver, and sat box to try and reset the memory. I was told by Toshiba to try to turn on the TV 1st, receiver 2nd , sat box or other input 3rd . but I still get nothing. It seems as if the TV wants to find it cause the screen blinks but doesn’t pick up the picture. Should I keep trying or just give up?

  4. #4
    Music Lover
    Join Date
    Jun 2009
    Location
    Los Angeles, CA
    Posts
    66
    Hi Bigal.

    Yeah. It sounds like the receiver is the problem. Here's a link to discussion thread about this receiver. Poke around there and is you can find the solution to your problem.
    Yamaha RX-V665 Discussion

    Good Luck.
    Rudy

  5. #5
    Suspended
    Join Date
    Mar 2002
    Location
    St. Louis, MO, USA
    Posts
    10,176
    If it worked once I doubt if it's a hand shake problem. Ask Toshiba or check your manual to see if the TV is HDCP compliant. If it is newer within the last few years it probably is. I believe it's the receiver. I have a Toshiba and haven't had any problems with HDMI. Mine is an older DLP.

    Have you assigned the video input you are using to the selector setting? Once this is done you may have to save the choice some how. For instance, on the receiver you may push "satelite", but since the receiver don't know what type of connection you will use you have to tell it HDMI inside the receiver's settings.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •