• 11-12-2005, 10:00 AM
    Cumminspuller
    Help with Polk RTi150's.........
    I am trying to install the jumpers to the binding posts. But I can not get the red and black binding post nuts off all the way to slide the jumper over the studs? Any help would be greatly appreciated.

    Jason
  • 11-12-2005, 01:55 PM
    Design Flaw
    Quote:

    Originally Posted by Cumminspuller
    I am trying to install the jumpers to the binding posts. But I can not get the red and black binding post nuts off all the way to slide the jumper over the studs? Any help would be greatly appreciated.

    Jason

    Yes, Polk does not let you pull the screws all the way off w/o breaking them provided they are all plastic like on my Monitor 70's. So that's what I did and replaced them with a new set from PartsExpress. I emailed Polk about this and they said they would fix this in the future. But they've been doing for a while (my Polk RTi600's had the same assinine problem), so I don't know what the deal is.

    After many years of being a loyal Polk customer, I've given up on them. There are many better speakers out there, even at their price-point.
  • 11-13-2005, 08:00 AM
    Cumminspuller
    Thank you for helping out here. I ended up with these because of the price. To low to pass up from a friend. They have done everything I have wanted them to today and have been happy with them. Thanks again.

    Jason
  • 11-13-2005, 05:33 PM
    caniac
    What's funny is, the instruction manual will tell you that if you want to use banana plugs that you are supposed to unscrew the nuts all the way to get those little caps off. Duh.