Results 1 to 2 of 2
  1. #1
    AR Newbie
    Join Date
    Feb 2005
    Posts
    1

    Buzzing sound from Carver C1000A amp

    Over the last few months, I have noticed a buzzing sound coming from my Carver C1000A. The sounds starts out very low and then gets progressively louder. It goes away if I power cycle the amp a few minutes but usually returns.

    I have a Monster power conditioner powering all the components-it also reports everything as grounded properly!

    I'm all out of ideas. Any ideas?

  2. #2
    Forum Regular royphil345's Avatar
    Join Date
    Apr 2002
    Posts
    709
    Can't tell you for sure, but my best guess is that the power supply capacitors are in need of replacement. When mine died, the first things I noticed were unexplained hum problems (that actually got worse when the amp was plugged into a grounded outlet) and thin sounding bass.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. The Nuance thread
    By Mike H in forum Speakers
    Replies: 8
    Last Post: 02-06-2005, 02:45 AM
  2. My receiver is making a buzzing sound
    By Z3r0 in forum Amps/Preamps
    Replies: 1
    Last Post: 10-23-2004, 06:58 AM
  3. Looking for a certain type of speaker
    By nahmed in forum Speakers
    Replies: 16
    Last Post: 08-31-2004, 10:14 AM
  4. Got a question about a small philips sound system
    By skitallz in forum Home Theater/Video
    Replies: 7
    Last Post: 01-22-2004, 05:58 AM
  5. Look what i found!
    By PeteintheUk in forum How-To Articles
    Replies: 0
    Last Post: 12-17-2003, 03:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Latest AudioReview Articles

Hot Deals

Latest News

AudioReview on Facebook