• 01-23-2010, 10:17 PM
    RoadRunner6
    Emotiva ERC-1 software upgrade
    For any ERC-1 owners, Emotiva has a software fix for a slight glitch some owner's were experiencing. The problem was only upon first powering on the ERC-1 and playing a CD. The first second or two would be cut off. This did not happen again with the same of other CD as long as the ERC-1 was on. This problem would only repeat itself when the ERC-1 was turned off (standby) and then on again and another CD played and again only the first one or two seconds.


    From the Emotiva Forum:

    "...............The software has been updated to hold the drive while the buffer locks, making sure that the first second of the disc does not get cut off. You can't do the update by simple burning the .BIN file I posted to a CDR. It has to be copied from a master CD that has specific formatting.

    Email me with your name and address, and I'll mail you a CDR.

    danng@emotiva.com

    Put 'ERC' in the subject header................"


    I did have this issue and have e-mailed Dann. For the complete thread see the below link:

    http://emotivalounge.proboards.com/i...ad=8795&page=1
  • 01-24-2010, 04:11 AM
    kexodusc
    Hmm, I couldn't get mine to do it...don't think I'll bother with this firmware update.
  • 01-24-2010, 11:11 AM
    Mr Peabody
    I didn't notice the problem at first but later I did. I really didn't think much of it until now. I did email for the update, it would bug me knowing there was one and I didn't do it.

    RR-6, Thanks for the heads up. Did you get your preamp processor? I heard they were shipping but if you posted anything I missed it. If you got it fill us in.
  • 01-24-2010, 11:29 AM
    harley .guy07
    Thats pretty cool of Emotiva to quickly take care of a problem in a timely manner and without every customer having to pay to have their units shipped back to them for repair
  • 01-24-2010, 01:13 PM
    RoadRunner6
    Quote:

    Originally Posted by Mr Peabody
    I didn't notice the problem at first but later I did. I really didn't think much of it until now. I did email for the update, it would bug me knowing there was one and I didn't do it.

    RR-6, Thanks for the heads up. Did you get your preamp processor? I heard they were shipping but if you posted anything I missed it. If you got it fill us in.


    Mr. P, the pre-pro that was just released was the UMC-1 - $699, which is having the usual first batch release glitches. Emotiva is working to get them resolved and issue upgrades.

    I am on the pre-order list for the upscale XMC-1 model, about $999-$1199. It will include a phono preamp plus more and hopefully should be out in a few months.

    So far, glitches aside, the preliminary feedback on the UMC-1 is that the sound quality and video processing are outstanding. These of course were several of the big questions before its release. To Emotiva's credit they are very open about the problems and seem to be working very hard on resolving these in an open manner, kudos to them. :biggrin5:
  • 01-24-2010, 01:18 PM
    RoadRunner6
    Quote:

    Originally Posted by harley .guy07
    Thats pretty cool of Emotiva to quickly take care of a problem in a timely manner and without every customer having to pay to have their units shipped back to them for repair

    Apparently it is just a simple software adjustment. For some technical reason they couldn't handle it as a download/CD-R solution so they are sending out the CD-R's by mail and very fast, in two days or so.