Need help with my Pioneer XD-Z53T Stereo [Archive] - Audio & Video Forums

PDA

View Full Version : Need help with my Pioneer XD-Z53T Stereo



Minus
05-04-2010, 07:26 AM
Hi all was hopeing maybe someone here could help me, I've had my Pioneer XD-Z53T system for about 15 years, when I got it the CD tracks were not alligned so I had to open it up and put the tracking system back together, that is the only problem I've had with it in all this time up until about 2 weeks ago, I have started to get a very loud hiss from the speakers when a CD is playing, most of the time it is over powering the music. I rang Pioneer support and they think it is the pick up assembly and would have to be replaced which will cost about 150! I have it connected to my pc VIA the AUX connection on the back and audio played fine even when CD's didnt but now I can hear it slowly and almost quietly starting to break through when sound is being played from the PC also. I dont know what to do, I have cleaned it out today and still no joy, stays the same. I dont want to think it is the end as it has lasted this long. Please if someone could help me it would be greatly appriciated, thank you.

JohnMichael
05-04-2010, 11:25 AM
When you close a thread no one can answer you. I opened it.

poppachubby
05-04-2010, 11:38 AM
10 years is about the life span of a typical, well used CDP. You have been lucky to have no issues until now. Many don't make it to even 5. Time to buy another. Don't be so attached, there is a whole world of wonderful players out there.

markw
05-04-2010, 11:41 AM
When you close a thread no one can answer you. I opened it.Maybe deep down inside he knew what the inevitable answer would be and didn't want to hear it...