Help with Wharfedale diamond 8.2 speakers [Archive] - Audio & Video Forums


View Full Version : Help with Wharfedale diamond 8.2 speakers

11-19-2006, 08:35 PM
I have just recently purchased a set of wharfedale Diamond 8.2 speakers today. When I purchased them they sounded fine, but when I got home was testing them here is what happened:

I plugged one of the speakers into an amplifier and tried to listen but all I got was High range (through tweeter) the mid or sub did not work…
I tried using the second speaker but did not use an amplifier but used a direct rca cable from ipod to speaker, and I could here everything from this 2 nd speaker.
tried to do the same thing using direct connection from ipod to speaker using rca cable but it did not work with the first speaker

so What could I have done to this speaker? Could it have gotten damaged in Transport? Or from being plugged into an amp? Are their any rest switch inside the speaker since it has a built in Amp and crossover….

PLEASE help me… Thank You very much,

11-19-2006, 10:00 PM
Hey there, Welcome to AR.

From what I understand, they are bi-wireable speakers. Do you have them bi-wired. Not sure if they come with stock jumpers. If they do, maybe they it was detached from your 1st speakers. If it didnt come with jumpers, it doesnt make any sense that your 2nd speaker played fine. So maybe you can check to see if it's in a secure position.

I dont quite understand how you hooked up your ipod to your speakers thru RCA cables though. 8.2s have RCA inputs? Maybe you have a pair of Pro Monitors. If you do, you shouldnt only hook'em into pre outputs from your preamp/CDP/phono pre. I've never seen a poweramp with RCA outputs. If that's the case, then it could be possible that the 1st one maybe faulty. But not sure.

BTW, Is Wharfedale using the same Kevlar woofers used by B&W? They look awefully familiar....


11-19-2006, 10:08 PM
since it has a built in Amp and crossover….

oh..... helps to read. I would contact your seller after making sure you had your cables plugged in correctly and tried using your CDP's preout with a couple of different interconnects.