• 11-22-2010, 06:59 PM
    seafrost
    Kenwood KD-2000 Restoration
    Got this table for standing up in my brothers wedding but it has a few issues. The audio cables were snipped and need to be replaced and the auto return function doesnt work. Here are some picture of my progress:

    I want to connect these to the table
    http://i3.photobucket.com/albums/y54...s/IMG_4193.jpg

    Here are the posts that the tonearm wires mount. Last thing I tried was stripping back the tonearm wires and audio cables, tinning the tips, and twisting them together through these posts, and then soldering them. Everytime I connected it to my reciever I heard no audio out of the audio cables at all. I know the receiver works because I have another table I am using now.
    http://i3.photobucket.com/albums/y54...s/IMG_4201.jpg
    http://i3.photobucket.com/albums/y54...s/IMG_4210.jpg
    http://i3.photobucket.com/albums/y54...s/IMG_4220.jpg
    http://i3.photobucket.com/albums/y54...s/IMG_4224.jpg
    http://i3.photobucket.com/albums/y54...s/IMG_4226.jpg

    Now 2 of the tone arm wires (one black and one green) were broken when i first opened it up so i had to patch it with solder and heat shrink tubing but I would like to just rewire the whole tone arm. Is this impossibly hard? I cant figure out how refish new wires down the tone arm. I just feel like a patch in those cables is going to degrade my signal a lot.

    Now as far as the auto return, i havent done many turntable repairs and Im not really sure where it is or what it looks like.

    ANY help is welcome seeing as how there are no service manuals and very little info available on this turn table
  • 11-22-2010, 10:25 PM
    dakatabg
    I checked online but couldn't find the manual! I see you registered at audiokarma too!
  • 11-23-2010, 05:50 AM
    seafrost
    Yea im trying a digital forum attack on all fronts! I am determined to get this thing fixed!