Results 1 to 1 of 1
  1. #1
    mjm
    mjm is offline
    AR Newbie Registered Member
    Join Date
    Aug 2005
    Posts
    1

    (Teledyne) Acoustic Research C-06 preamp -help needed please

    Hi - I have the above preamp which has suddenly "died". Mains to unit ok, plus mains to switched power output(mains) on back of unit. No indicator lights for source selected, no output to main amp and no headphone socket output. Both slow-blow fuses intact on circuit board. As I live in Spain and have to take it to a repair shop - does anyone have any clues please - or a circuit diagram?
    You will be pleased to know it is raining here today!
    Thanks
    Last edited by mjm; 08-21-2005 at 05:42 AM. Reason: To add information

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What happened to the comapy acoustic research
    By Ricardo ferreira in forum News & Rumors
    Replies: 7
    Last Post: 03-29-2005, 09:40 AM
  2. acoustic research specialist??? need help!!!
    By Lokoseena in forum The Audio Lab, Tweaks, Mods, DIY
    Replies: 4
    Last Post: 08-23-2004, 11:44 AM
  3. Acoustic Research S108PS
    By yguelce in forum General Audio
    Replies: 1
    Last Post: 08-04-2004, 10:08 PM
  4. Acoustic Research speakers?
    By lbhkilla in forum Speakers
    Replies: 0
    Last Post: 05-13-2004, 05:18 PM
  5. Acoustic Research AR HC6
    By cokaznrebel in forum Speakers
    Replies: 3
    Last Post: 11-19-2003, 06:34 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •