Results 1 to 2 of 2
  1. #1
    AR Newbie
    Join Date
    Feb 2005
    Posts
    1

    Nad C 370 needs some help...

    Hello Everybody!

    After 3.5 years runing my NAD 370, it started to show me some horrible problems:

    After switching On the amp, the right chanel (just right) is horribly distorted, low sound and almost difficult to hear. The only one solution(quick one) brings back to the normal sound is: I`m adjusting volume control up to 2/3 of signal, then the strong signal "brakes through" the distortion, low sound goes up, and the chanel begins to perform normaly. I swapped speakers- it changes nothing.
    It hapends ones in four times...so I have some sneaky suspicion about the last days of my NADy...
    Does anybody know what is wrong and is it posible to reanimate my NADy...please.

    Thanks


    Nakamichi MB10 cdplayer
    Denon radio tuner T 260LII
    NAD C 370 amplif.
    KEF Q7 speakers (bi-wired)
    Van Den Hul Mk III Hybrid Interconnectors
    QED silver anniversary be-wired speaker cable

  2. #2
    Suspended markw's Avatar
    Join Date
    Dec 2001
    Location
    Noo Joisey. Youse got a problem wit dat?
    Posts
    4,676

    ...alomst sounds like a dirty volume pot.

    If it is, a quick spritz of contact tv leaner/lubricant should clear it up. NAD isn't inherently bad stuff. I'm running a 1600 tuner/preamp from the early 90's and have had no problems.
    Granted, the pot should have lasted more than 4 years but if the cheap fix works, consider it a blessing.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Latest AudioReview Articles

Hot Deals

Latest News

AudioReview on Facebook